Некоторые клиенты спросили нас о возможности изменить версию PHP в учётной записи веб-хостинга cPanel.

NB! различия в версиях PHP:
– После 01.05.2023 версия PHP по умолчанию на наших серверах (вместо 7.4) — PHP 8.1!

Дополнительная информация:
Мы используем на наших серверах отдельные версии PHP, в которых даже старые версии по прежнему получают исправления безопасности и обновления.
Вы можете прочитать больше об этом на следующей странице:
https://www.cloudlinux.com/hardenedphp
(Если Ваша веб-страница/скрипт/и т. д. поддерживает более новую версию PHP, тогда рекомендуем обновить версию PHP до новейшей поддерживаемой версии!)


1. Изменение версии PHP в среде cPanel

1. Войдите на учётную запись веб-хостинга (в среду cPanel)
2. Выберите “MultiPHP manager”
3. Выберите домен, затем выберите версию PHP из раскрывающегося списка справа и нажмите “Apply”.
(Новая версия PHP будет активирована автоматически вскоре после сохранения)
NB! Сохранение перезапишет версию PHP в файле .htaccess! Если Вы удалили эти изменения вручную, Вам необходимо сохранить их повторно!


2. Примеры, как запустить скрипт с необходимой версией PHP через командную строку (работает также через CRON)

Примеры команд для запуска скрипта с желаемой версией PHP:

Cron:
/bin/ea-php56 /path/to/required/script.php
/bin/ea-php70 /path/to/required/script.php
/bin/ea-php71 /path/to/required/script.php
/bin/ea-php72 /path/to/required/script.php
/bin/ea-php73 /path/to/required/script.php
/bin/ea-php74 /path/to/required/script.php
/bin/ea-php80 /path/to/required/script.php
/bin/ea-php81 /path/to/required/script.php
/bin/ea-php82 /path/to/required/script.php
----
Командная строка:
ea-php56 /path/to/required/script.php
ea-php70 /path/to/required/script.php
ea-php71 /path/to/required/script.php
ea-php72 /path/to/required/script.php
ea-php73 /path/to/required/script.php
ea-php74 /path/to/required/script.php
ea-php80 /path/to/required/script.php
ea-php81 /path/to/required/script.php
ea-php82 /path/to/required/script.php

NB! Если в папке или подпапке уже есть файл .htaccess с требуемой версией PHP, нет необходимости отдельно указывать точную версию PHP, достаточно напичсать “php /path/to/required/script.php”.


Radicenter 2024
Этот веб-сайт использует файлы cookie и аналогичные технологии для функциональности и других целей. Использование этого веб-сайта означает принятие Вами файлов cookie.
Соглашаюсь.